Is there some guideline or rationale behind why some WP code functions are prefixed with
wp_ ? eg:
This makes not that impressive answer, but – none.
get_ is suffix usually means function returns something,
the_ that function echoes something.
wp_ doesn’t carry technical meaning and inconsistency in naming is from many developers participating and lack of movement to unify (moving forward is considered more important than major cleanups of older stuff to make it neat).