Why were Javascript `atob()` and `btoa()` named like that?

In Javascript, window.atob() method decodes a base64 string and window.btoa() method encodes a string into base64.

Then why weren’t they named like base64Decode() and base64Encode()?
atob() and btoa() don’t make sense because they’re not semantic at all.

I want to know the reason.

5 Answers
5

Leave a Comment